Pomocni materijal za zavrsni ispit



split metoda klase String

m Metoda split klase String ,razbija“ predmetni string na podstringove
razdvojene delimiterima (spejs, tab, zarez, Enter...), i vra¢a niz String
objekata.

String recenica = "Java je mocan jezik.";

String reci[] = recenica.split(™ ");

for(String s: reci)
System.out.println(s);

Java _
je .— Ispis
mocan
jezik.

m Argument metode split moze biti regularan izraz, Cime se moze izvrsiti
slozenije razbijanje na podstringove.



Konverzija stringa u numericke tipove

public class Test {

public static void main(String[] args) {
String strInt = "100", strDouble = "67.89";
int cio = Integer.parselnt(strint);
double real = Double.parseDouble(strDouble);
System.out.printf("Cio broj: %d, realan: %f", cio, real);

}
}

Ispis
Cio broj: 100, realan: 67.890000




OBJEKTNO-ORUENTISANI DIZAJN SOFTVERA

List kolekcija

List je uredena kolekcija koja moze sadrzati duplikate elemenata.

Kao kod nizova, indeks prvog elementa liste je 0. Za razliku od nizova,
elementima se ne moze pristupiti koristeCi zagrade [ ], vec preko
odgovarajucih metoda (set i get).

Pored metoda nasledenih iz interfejsa Collection, interfejs List
obezbeduje niz metoda za rad sa elementima liste (preko indeksa), rad
sa opsegom elemenata liste, pretragu elemenata itd.

Nekoliko klasa implementira interfejs List, od kojih su najcesce
koriSCene ArrayList i LinkedList.

ArrayList se implementira kao niz promenljive duzine. Stoga su
operacije gde se Cesto menja broj elemenata ArrayList objekta
neefikasne.

LinkedList sa implementira kao povezana lista. Umetanje novih
elemenata u sredinu liste, brisanje elemenata liste i slicho su znacajno
efikasniji u odnosu na ArrayList objekte.



Neke metode | osobine klase ArrayList

Metoda Opis

add Dodavanje elementa na kraj kolekcije ili na odredenu poziciju.

clear Brisanje kolekcije (uklanjanje svih elemenata).

contains Vraca true ako kolekcija sadrzi trazeni element i false u
suprotnom.

get Vraca element sa specificiranim indeksom.

set Postavlja vrijednost elementu sa specificiranim indeksom.

indexOf Vracda indeks prve pojave specificiranog elementa kolekcije.

remove Uklanja prvu pojavu specificirane vrednosti ili elementa sa
specificiranim indeksom.

size Vraca broj elemenata smestenih u ArrayList kolekciji.

toArray Konvertovanje kolekcije u niz. Ovo se radi da bi se odredene
operacije sa nizom izvele efikasnije, kao i da bi se konvertovani niz
mogao proslediti metodama koje ne rade sa kolekcijama ili
obraditi nasledenim starim kodom koji ne poznaje kolekcije.

trimToSize Smanjenje kapaciteta kolekcije na trenutni broj elemenata.




Klasa ArrayList — Primer

import java.util.Arraylist;
public class PrimerArraylList {

public static void main(String[] args) {
ArraylList< String > kolString = new ArraylList< String >();

System.out.printf("Pocetna velicina: %d\n", kolString.size());

kolString.add("Prvi");
kolString.add("Drugi");
kolString.add(@,"Treci");
kolString.add(1,"Cetvrti");

System.out.printf("Velicina nakon dodavanja: %d\n", kolString.size());

System.out.printf("Kolekcija nakon dodavanja: ");

for(String s: kolString)
System.out.printf("%s

> S);

String[] nizString = new String[kolString.size()];

kolString.toArray(nizString);

System.out.printf("\nNiz nakon kopiranja kolekcije u niz: ");

for(String s: nizString)
System.out.printf("%s

> S);

// Nastavak na narednom slajdu...
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System.out.printf("\nU kolekciji %s elementa %s",

kolString.contains("Treci") ? "ima" : "nema", "Treci");
System.out.printf("\nU kolekciji %s elementa %s\n",
kolstring.Contains(upetin) ? "ima" . nnemau, "Peti");

kolString.remove("Treci");

System.out.printf("Kolekcija nakon uklanjanja elementa Treci: ");

for(String s: kolString)
System.out.printf("%s

kolString.remove(0);

System.out.printf("\nKolekcija nakon uklanjanja elementa sa indeksom @: ");

for(String s: kolString)
System.out.printf("%s

> S);

> S);

kolString.clear();
System.out.printf("\nVelicina nakon brisanja kolekcije: %d", kolString.size());

}

Pocetna velicina: @

Velic¢ina nakon dodavanja: 4

Kolekcija nakon dodavanja: Treci Cetvrti Prvi Drugi

Niz nakon kopiranja kolekcije u niz: Treéi Cetvrti Prvi Drugi :
U kolekciji ima elementa Tredi < ISFNS
U kolekciji nema elementa Peti

Kolekcija nakon uklanjanja elementa Trec¢i: Cetvrti Prvi Drugi
Kolekcija nakon uklanjanja elementa sa indeksom ©: Prvi Drugi
Velic¢ina nakon brisanja kolekcije: ©
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Korisne metode LinkedList kolekcije

Dodaje element na kraj LinkedList kolekcije (verzija metode

add sa jednim parametrom) ili na odredenu poziciju (pozicija prvi
parametar, element drugi parametar).
addFirst , . . .
lement na prv nosno zadn ZiCi listi.
ddLast Dodaju element na prvu, odnosno zadnju poziciju u list
addAll Nadovezuje kolekciju (parametar metode) na predmetnu listu.
Uklanja prvu pojavu specificirane vrednosti ili elementa sa
remove specificiranim indeksom. Specificirana vrednost ili indeks su
parametri metode.
removerirst Uklanjaju prvi, odnosno zadnji element liste.
removelLast
clear BriSe kolekciju (uklanja sve elemente).
i Vraca true ako kolekcija sadrzi trazeni element i false u
contailns
suprotnom.
get Vraca element sa specificiranim indeksom.
) Vraca indeks prve pojave specificiranog elementa kolekcije,
indexOf .
odnosno -1 ako element ne postoji
size Vraca broj elemenata smeStenih u kolekciji.

toArray

Konvertovanje kolekcije u niz.



asList metoda klase Arrays

m asList metoda klase Arrays omogucava da se predmetni niz posmatra
kao List kolekcija.

m aslList metoda vraca List izgled (eng. List view) niza, koji se u tom
sluCaju naziva podrzavajuci niz (eng. backing array).

m Bilo kakva promena List izgleda menja podrzavajuci niz i obrnuto.

m Jedina dozvoljena operacija na List izgledu koga vraca metoda asList
je set, koja menja vrednost elementa izgleda i odgovarajuceg elementa
niza.



2 OBJEKTNO-ORIENTISANI DIZAJN SOFTVERA
Primer za asLIst

import java.util.lList;
import java.util.Arrays;

public class aslListPodrzavajuciNiz {

public static void main(String[] args) {
String imena[] = {"Teodora", "Enis", "Robert", "Marija", "Ana"};

List< String > lista = Arrays.asList(imena);
System.out.printf("PocCetna lista:\n%s\n", lista);

lista.set(@, "Milutin");
imena[1] = "Eva";

System.out.println("Krajnji niz:");
for(String ime: imena)

System.out.print(ime + " ");

System.out.printf("\nKrajnja lista:\n%s", lista);

Ispis

Pocetna lista:

[Teodora, Enis, Robert, Marija, Ana]
Krajnji niz:

Milutin Eva Robert Marija Ana
Krajnja lista:

[Milutin, Eva, Robert, Marija, Ana]

10
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Primer za asList | toArray

import java.util.lLinkedList;
import java.util.Arrays;

public class AsListToArray {
public static void main(String[] args) {

String imena[] = {"Petar", "Milan", "Teodora"};

System.out.println("PocCetna lista:\n" + lista);

lista.add("Rade");
lista.add(2, "Vesna");
lista.addFirst("Marija");

System.out.printf("Lista nakon dodavanja:\n%s\n", lista);
imena = lista.toArray(new String[lista.size()]);

System.out.println("Niz nakon kopiranja liste:");
for(String ime: imena)
System.out.print(ime + " ");

LinkedList< String > lista = new LinkedList< String >(Arrays.asList(imena));

Ispis

Pocetna lista:
[Petar, Milan, Teodora]
Lista nakon dodavanja:

Niz nakon kopiranja liste:

[Marija, Petar, Milan, Vesna, Teodora, Rade]

Marija Petar Milan Vesna Teodora Rade




Klasa Collections

m Klasa Collections obezbeduje nekoliko efikasnih algoritama za

manipulaciju elementima kolekcije. Ovi algoritmi su implementirani kao

statiCke metode. NajCeSce koriScene metode su date u tabeli ispod.

Metoda Opis

sort Sortiranje elemenata liste.

binarySearch Trazenje elementa liste.

reverse Obrtanje redosleda elemenata liste.

shuffle Slucajno rasporedivanje elemenata (mesanje) liste.
fill Upisivanje odredene reference u svaki element liste.
copy Kopiranje reference iz jedne liste u drugu.

min Vraca minimalan element kolekcije.

max Vraca maksimalan element kolekcije.

addAll Nadovezivanje elemenata niza na kolekciju.

12



Primer sa klasom Collections

import java.util.Collections;
import java.util.Arraylist;
import java.util.lList;

import java.util.Arrays;

public class CollectionsTest {

public static void main(String[] args) {
Integer niz[] = {3, 4, 11, 9, 7, 4, 17, 1};

List< Integer > lista = new ArraylList< Integer >(Arrays.asList(niz)); |SFHS
System.out.printf("Pocetna lista:\n%s ", lista); Potetna lista:

[3, 4, 11, 9, 7, 4, 17, 1]
System.out.printf("\nMinimum liste %d, maksimum %d.", Minimum liste 1, maksimum 17.

Collections.min(lista), Collections.max(lista));

Collections.sort(lista);
System.out.printf("\nLista nakon rast. sortiranja:\n%s", lista); | Lista nakon rast. sortiranja:
Collections.sort(lista, Collections.reverseOrder()); [1, 3, 4, 4, 7, 9, 11, 17]
System.out.printf("\nLista nakon opad. sortiranja:\n%s", lista); | Lista nakon opad. sortiranja:
[17, 11, 9, 7, 4, 4, 3, 1]
Collections.shuffle(lista);
System.out.printf("\nLista nakon mesSanja:\n%s", lista); Lista nakon mesSanja:

[9, 11, 3, 1, 7, 4, 17, 4]
Collections.addAll(lista, 5, 13);
System.out.printf("\nLista nakon dodavanja:\n%s", lista); Lista nakon dodavanja:

[9, 11, 3, 1, 7, 4, 17, 4, 5, 13]
Collections.fill(lista, 7);

System.out.printf("\nLista nakon zamene elemenata\n%s", lista); Lista nakon zamene elemenata
} (7, 7, 7, 7, 7, 7, 7, 7, 7, 7]

} | o




Interfejs Comparator

m Comparator je generiCki interfejs iz paketa java.util koji se koristi za
sortiranje objekata korisniCkih klasa. U odnosu na Comparable interfejs:

e« omogucava poredenje i sortiranje po vise kriterijuma,

* ne zahteva izmenu originalne klase, odnosno omogucava poredenje za

klase Ciju realizaciju ne mozemo modifikovati.

m Comparator interfejs omogucava proizvoljan broj naCina sortiranja elemenata
predmetnog tipa. Za svaki nacin sortiranja, potrebno je da definiSemo klasu
koja implementira generiCki interfejs Comparator< Tip >, u okviru koje ¢emo

realizovati metodu compare. Ova metoda ima dva parametra - objekte

predmetnog tipa koje poredi, i vraca negativan ceo broj ako je prvi parametar

objekat manji od drugog, pozitivan ceo broj ako je prvi parametar veci od

drugog, i 0 ako su jednaki.

import java.util.Comparator;
public class CovekRastuci implements Comparator< Covek > {
public int compare(Covek prvi, Covek drugi) {

double visl = prvi.getVisina(); double tezi
double vis2 = drugi.getVisina(); double tez2
if((visl == vis2) && (tezl == tez2)) return 0;
else if((visl > vis2) || ((visl == vis2) && (tezl > tez2)))
else return -1;

prvi.getTezina();
drugi.getTezina();

return 1;

14



Skupovi. HashSet

m Skup (eng. set) predstavlja kolekciju jedinstvenih elemenata.

m Postoji nekoliko Set implementacija, od kojih su najpopularniji
HashSet | TreeSet.

m HashSet smesta elementa u hash tabeli ili hash mapi, dok TreeSet
smesSta elemente u stablu. U TreeSet-u, elementi su sortirani.

m HashSet je klasa iz paketa java.util koja za smestanje i
Indeksiranje elemenata koristi hash tabelu.

add Dodaje element (parameter metode) u HashSet ukoliko taj element ne
postoiji.

addAll Nadovezuje elemente niza (drugi parametar) na kolekciju (prvi parametar)

remove Uklanja objekat (parametar metode) iz skupa.

clear BriSe sve elemente iz skupa.

contains Proverava da li postoji element (parameter metode) u skupu i vraca true
ako postoji, odnosno false ako ne postoiji.

isEmpty Vraca true ako je skup prazan, false u suprotnom.

size Vraca broj elemenata (kardinalni broj) skupa. 15



Klasa TreeSet

m TreeSet implementira SortedSet interfejs, koji nasleduje Set interfejs.

m Sve kolekcije koje implementiraju SortedSet interfejs imaju sortirane
elemente, bilo u prirodnom poretku (npr. rastuci redosled za brojeve) ili u
poretku koji definiSe Comparator objekat prosleden TreeSet
konstruktoru.

m Osnovne operacije sa elementima (dodavanje, uklanjanje i1 provera da li
element postoji) kod TreeSet-a su sporije hego kod HashSet-a, ali joS
uvek mnogo brze nego kod nizova ili povezanih listi.

m Ako TreeSet sadrzi N elemenata, potrebno je u proseku log,N poredenja
Zza ove oshovne operacije, dok je kod HashSet-a slozenost ovih operacija
konstantna, tj. ne zavisi od broja elemenata.

m TreeSet ima Cetiri konstruktora. Pomenimo 1) konstruktor sa parametrom
kolekcijom Cije elemente kopira u kreiranu TreeSet instancu I sortira
prema prirodnom poretku, i 2) konstruktor sa parametrom komparatorom
koji definiSe poredak elemenata.

16



Primer sa Set-ovima

import java.util.Comparator;

public class KomparatorStringova implements Comparator<String> {
public int compare(String prvi, String drugi) {
return prvi.length() - drugi.length();
}

public class HashSetTreeSet { } Duzina stringa kao kriterijum poredenja

import java.util.*;

public static void main(String[] args) {
String nizImena[] = {"Ana", "Marko", "Robert", "Esma", |"Dalibor",
"Igor", "Ivana", "Marko", "Robert"| "Ana"};

Set< String > hSet = new HashSet< String >(Arrays.aslList(nizImena));
Set< String > tSetl = new TreeSet< String >(hSet);

Set< String > tSet2 = new TreeSet< String >(new KomparatorStringova());
tSet2.addAll(tSetl);

System.out.printf("HashSet:\n%s", hSet);
System.out.printf("\nTreeSet (prirodni poredak):\n%s", tSetl);
System.out.println("\nTreeSet (korisnicki definisan poredak):");
for(String ime: tSet2)

System.out.print(ime + " ");

}

HashSet:

[Esma, Igor, Ana, Robert, Marko, Dalibor, Ivana]
TreeSet (prirodni poredak):

[Ana, Dalibor, Esma, Igor, Ivana, Marko, Robert]
TreeSet (korisnicki definisan poredak): 17
Ana Esma Ivana Robert Dalibor
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Mape
m Za razliku od skupova, koji sadrze samo vrednosti, vrednosti mape (eng. map) su
parovi klju¢-vrednost (eng. key-value).

m Mapa je objekat koja mapira (preslikava) kljuCeve u vrednosti. KljuCevi u mapi
moraju biti jedinstveni, dok odgovarajuce vrednosti ne moraju biti. KljuCevi i
vrednosti mogu biti proizvoljni referencijski tipovi.

put

putAll
get

remove

clear
containsKey

containsValue
keySet

values

entrySet

isEmpty
size

Dodaje klju€ (prvi parameter) i odgovarajucu vrednost (drugi parameter) u mapu. Ukoliko klju¢ ve¢ ima
pridruzenu vrednost, metoda menja staru vrednost novom.

Primer: Ako je kljuC tipa String, a vrednost Integer, naredba mapa.put("Valjevo", 14000) Ce dodati klju¢
"Valjevo" sa pripadajucom vrednosScu 14000 u mapu.

Kopira sve parove klju¢-vrednost iz mape parametra u predmetnu mapu.

Vraca vrednost koja odgovara klju€u (parametar metode), odnosno null ako ne postoji ta vrednost.

Primer: Naredba mapa.get("Valjevo") ¢e vratiti vrednost 14000, nakon naredbe iz primera put metode.
Uklanja par klju¢-vrednost iz mape za prosledeni klju€ (parametar metode) iz mape. Metoda vraca vrednost
dodeljenu klju¢u, odnosno null ako postoji predmeti par klju¢-vrednost.

BriSe sve parove klju¢-vrednost iz mape.
Vraca true ako mapa sadrzi mapiranje sa predmetnim klju¢em, false ako ne sadrzi.

Vrac¢a true ako mapa sadrzi jedno ili viSe mapiranja sa predmetnom vrednoscu, false ako ne sadrzi.

Vrac¢a Set izgled (eng. Set view) kljuCeva mape. Mapa podrzava skup kljuCeva, tako da se promene na mapi
odrazavaju na skup i obrnuto.

Vraca Collection izgled (eng. Collection view) vrednosti sadrzanih u mapi. Mapa podrzava kolekciju, tako da
se promene na mapi odrazavaju na kolekciju i obrnuto.

Vrac¢a Set izgled parova klju¢-vrednost sadrzanih u mapi. Mapa podrzava skup kljueva, tako da se promene
na mapi odraZzavaju na skup i obrnuto.

Vraéa true ako je mapa prazna, false u suprotnom.
Vraca broj parova klju¢-vrednost mape.
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Mape

m Neke od klasa koje implementiraju interfejs Map su HashTable, HashMap i
TreeMap. HashTable i HashMap smestaju elemente u hash tabelama, dok
iIh TreeMap smesta u stablo.

m [nterfejs SortedMap nasleduje Map, i klase koje implementiraju SortedMap
imaju sortirane kljuCeve. Klasa TreeMap implementira SortedMap.

m HashTable, HashMap | TreeMap su generiCke klase Cije instance se
kreiraju na sledeci nacin (dajemo primer sa HashMap):

Map< K, V > map = new HashMap< K, V >();
gde K i V predstavljaju tip kljuCa i vrednosti, respektivno.

m U nastavku dajemo primer koriS¢enja mape za brojanje pojava svake reci
u datom tekstualnom fajlu.
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Primer sa TreeMap

import java.io.IOException;

import java.nio.charset.StandardCharsets; Set< String > kljucevi = mapa.keySet();
import java.nio.file.*; int k = 1;
import java.util.*; for(String rec: kljucevi)
public class RadSaMapom { System.out.printf("%-13s%3s%s", rec,
mapa.get(rec), (k++ % 4 == 0)?2 “\n" : " | ");
public static void main(String[] args) { }
List< String > listalinija = null; ¥
try {

Path putanja = Paths.get("C:\\Temp\\Tekst.txt");

listalinija = Files.readAllLines(putanja, StandardCharsets.UTF 8); }
catch(IOException e) {

System.err.println("Greska prilikom ¢itanja fajla.");

System.exit(1); }

Map< String, Integer > mapa = new TreeMap< String, Integer >();

for(String linija: listalLinija){
linija = linija.toLowerCase();
String reci[] = linija.split("[ ,.;!?-1");
for(String rec: reci){
if(rec.length() > 0)
if(mapa.containsKey(rec))
mapa.put(rec, mapa.get(rec) + 1);
else
mapa.put(rec, 1);

N
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SOFTVERA

Primer sa TreeMap

-

| Proba.txt - Notepad ! - # ’ #
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File Edit Format View Help

on the Insert tab, the galleries include items that are designed to coordinate with the overall Took of your document.
You can use these galleries to insert tables, headers, footers, 1ists, cover pages, and other document building blocks.
when you create pictures, charts, or diagrams, they also coordinate with your current document Jook. You can easil
change the formatting of selected text in the document text by choosing a look for the selected text from the quic
Styles gallery on the Home tab. You can also format text directly by using the other controls on the Home tab.

Most controls offer a choice of using the Took from the current theme or using a format that you specif% directly. To
change the overall look of your document, choose new Theme elements on the Page Layout tab. To change the looks
available in the qQuick style gallery, use the change cCurrent Quick style set command. Both the Themes gallery and the
qQuick styles gallery provide reset commands so that you can always restore the look of your document to the original
contained in your current template. On the Insert tab, the galleries include items that are designed to coordinate with
the overall look of {our document.

You can use these galleries to insert tables, headers, footers, lists, cover pages, and other document building blocks.
when you create pictures, charts, or diagrams, they

-

contained in your current template. On the Insert ta

and other document building blocks.

when you create pictures, charts, or diagrams, they also coordinate with your current document Jook. You can easi]{
change the formatting of selected text in the document text by choosing a look for the selected text from the quic
styles gallery on the Home tab. You can also format text directly by using the other controls on the Home tab. Most
controls offer a choice of using the look from the current theme or using a format that you specify directly. To change

, Tthe

the overall look of your document, choose new Theme elements on the Page Layout tab.

also coordinate with your current document look. You can easi1{

change the formatting of selected text in the document text by choosing a look for the selected text from the quic

Styles gallery on the Home tab. You can also format text directly by using the other controls on the Home tab. Most

controls offer a choice of using the Took from the current theme or using a format that you specify directly.

To change the overall look of your document, choose new Theme elements on the Page Layout tab. To change the looks I

availabTle in the qQuick style gallery, use the change current Quick style set command. Both the Themes gallery and the

qQuick styles gallery provide reset commands so that Eou can always restore the Tlook of your document to the original
galleries include items that are designed to coordinate with

the overall look of your document. You can use these galleries to insert tables, headers, footers, 1ists, cover pages,

Fajl

a 9 | also 6 | always 2 | and 5 | are 3
available 2 | blocks 3 | both 2 | building 3 | by 6

can 11 | change 10 | charts 3 | choice 3 | choose 3
choosing 3 | command 2 | commands 2 | contained 2 | controls 6
coordinate 6 | cover 3 | create 3 | current 10 | designed 3
diagrams 3 | directly 6 | document 17 | easily 3 | elements 3

footers 3 | for 3 | format 6 | formatting 3 | from 6
galleries 6 | gallery 9 | headers 3 | home 6 | in 7 .
include 3 | insert 6 | items 3 | layout 3 | lists 3 |Sp|S
look 7 | looks 2 | most 3 | new 3 | of 14

offer 3 | on 12 | or 6 | original 2 | other 6

overall 6 | page 3 | pages 3 | pictures 3 | provide 2

quick 9 | reset 2 | restore 2 | selected 6 | set 2

SO 2 | specify 3 | style 4 | styles 5 | tab 12

tables 3 | template 2 | text 12 | that 8 | the 56

theme 6 | themes 2 | these 3 | they 3 | to 13

use 5 | using 9 | when 3 | with 6 | you 17 21
your 13 |
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Rad sa fajlovima | folderima. Klasa File

m Klasa File (paket java.io) pruza niz korisnih metoda u radu sa fajlovima i
folderima (direktorijumima), od kojih je jedan broj dat u tabeli ispod.

exists Vraca true ako fajl ili folder predstavljen File objektom postoji, false u suprotnom.
isFile Vraca true ako ime prosledeno File konstruktoru odgovara fajlu, false u suprotnom.
isDirectory Vraca true ako ime prosledeno File konstruktoru odgovara folderu, false u suprotnom.

Vraca true ako argumenti prosledeni File konstruktoru odgovaraju apsolutnoj putanji do
fajla ili foldera, false u suprotnom.

getAbsolutePath Vraca String sa apsolutnom putanjom do fajla ili foldera.

isAbsolute

getName Vraca String sa imenom fajla ili foldera.
getPath Vraca String sa putanjom do fajla ili foldera.
getParent Vraca String sa roditeljskim (prvim iznad) folderom datog fajla ili foldera.

Vraca veli€inu fajla, izrazenu u bajtovima. Ako File objekat predstavlja folder, vra¢a se
nedefinisana vrednost.

Vraca vreme u long formatu (vrednost zavisi od platforme) poslednje modifikacije fajla ili
lastModified foldera. Vracena vrednost se moze Koristiti samo za poredenje sa drugim vrednostima koje
vraca ova metoda.

BriSe predmetni fajl ili folder. U sluc¢aju brisanja foldera, njegov sadrzaj se mora izbrisati pre
brisanja samog foldera. Vraca true ako je brisanje uspesno izvrSeno i false u suprotnom.
Vraca niz String objekata koji predstavlja sadrzaj foldera, odnosno null ako File objekat
ne predstavlja folder.

length

delete

list
22



a8~ OBJEKTNO-ORIJENTISANI DIZAJN SOETVERA
Klasa File

m Koristeci objekte klase File ne mozemo otvoriti fajlove, niti ih procesirati na
bilo koji nacin. Ovi objekti se obicno koriste u kombinaciji sa drugim java.io
klasama da specificiraju sa kojim fajlovima i folderima se konkretno radi.

m File klasa ima Cetiri konstruktora.

m Pomenimo ovde samo konstruktor sa parametrom stringom koji odreduje ime
fajla ili foldera koje Ce biti pridruzeno File objektu. Ime moze sadrzati i
putanju do fajla/foldera. Putanja moze ukljuciti samo neke ili sve foldere do
zeljenog pocCev od korenog foldera (npr. "C:\Prvi\Drugi\Treci").

m U nastavku dajemo primer koriS¢enja klase File. Od korisnika ¢emo traziti
unos putanje do fajla ili foldera, a nakon toga, ukoliko predmetni fajl/folder
postoji, odStampacemo nekoliko opisnih poruka vezanih za fajl/folder.
Dodatno, ako je u pitanju folder, odStampacemo i njegov sadrza;.
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Klasa File - Primer

import java.util.Scanner;
import java.io.File;

public class DemonstracijaKlaseFile {

public static void main(String [] args) {
Scanner unos = new Scanner(System.in);

System.out.print("Uneti ime fajla ili foldera: ");
File ime = new File(unos.nextLine());
if(ime.exists()) {
System.out.printf("%s\n%s\n%s\n%s\n%s\n%s",
ime.getName() + " postoji”,
ime.isFile() ? "To je fajl" : "To nije fajl",
ime.isDirectory() ? "To je folder " "To nije
"Velicina: " + ime.length() + " bajta",
"Poslednja izmena: " + ime.lastModified(),
"Roditeljski folder: " + ime.getParent());
}
else
System.out.printf("%s ne postoji", ime);

if(ime.isDirectory()) {
System.out.println("\n\nSadrzaj foldera:");
for(String f: ime.list())
System.out.println(f);
}

unos.close();

folder",
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Klasa File - Primer

lzvrSenje 1

Uneti ime fajla ili foldera: C:\Program Files (x86)\texstudio
texstudio postoji

To nije fajl

To je folder

Velic¢ina: 4096 bajta

Poslednja izmena: 1618300520977

Roditeljski folder: C:\Program Files (x86)

Sadrzaj foldera:
dictionaries
Doc.pdf

help

share

templates
texstudio.exe
TexTablet
translations
uninstall.exe

lzvrSenje 2

Uneti ime fajla ili foldera: C:\Program Files (x86)\texstudio\Doc.pdf
Doc.pdf postoji

To je fajl

To nije folder

Velic¢ina: 128946 bajta

Poslednja izmena: 1618234408258

Roditeljski folder: C:\Program Files (x86)\texstudio




Tekstualni fajlovi sa sekvencijalnim pristupom

m Demonstrirajmo rad sa tekstualnim fajlovima sa sekvencijalnim
pristupom.

m Sekvencijalni pristup podrazumeva da se podaci upisuju i Citaju jedan za
drugim. Nasuprot sekvencijalnom imamo slucajni pristup, gde bilo kad
mozemo pristupiti proizvoljnom podatku u toku.

m U prvom primeru ¢emo kreirati tekstualni fajl na osnovu unosa korisnika.
m U drugom primeru ¢emo otvoriti kreirani fajl i odStampati njegov sadrza,j.

m Pomenute radnje ¢emo demonstrirati pomoc¢u novokreirane klase
Radnik, prikazane na slede¢em slajdu.
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KI asa Rad n i k LocalDate klasa predstavlja datume, bez vremenske zone, u

ISO-8601 kalendarskom sistemu, npr. 2021-04-23.

import java.time.lLocalDate; “— Klasa DateTimeFormatter se koristi za formatiranje datuma.
import java.time.format.DateTimeFormatter;«—— Metoda ofPattern ove klase kreira formater datuma na
osnovu stringa $ablona. Sablon je kombinacija predefinisanih

bli 1 Radnik . . . . v
public class Radnik { slova i simbola za prikaz datuma. Na primer, Sablon "d MMM

private String ime;

private LocalDate pocetak;
private int sprema;

private static final DateTimeFormatter df = DateTimeFormatter.ofPattern("dd/MM/yyyy");

public Radnik() { this("", "", LocalDate.now(), ©); }
public Radnik(String ime, String prezime, LocalDate pocetak, int sprema) {
setIme(ime); setPrezime(prezime); setPocetak(pocetak); setSprema(sprema); }

public String getIme() { return ime; }

public void setIme(String ime) { this.ime = ime; }

public String getPrezime() { return prezime; }

public void setPrezime(String prezime) { this.prezime = prezime; }
public LocalDate getPocetak() { return pocetak; }

public void setPocetak(LocalDate pocetak) { this.pocetak = pocetak; }
public int getSprema() { return sprema; }

public void setSprema(int sprema) { this.sprema = sprema; }

@Override
public String toString() {
return String.format("%-10s %-12s sprema: %d pocetak: %s",
this.getIme(), this.getPrezime(), this.getSprema(),
df.format(this.getPocetak()));




Kreiranje txt fajla 1 upis u fajl

}

import java.util.*;
import java.io.*; public void zatvoriFajl() {
import java.time.lLocalDate; if(izlaz != null)

public class UpisRadnikaUFajl {

private static Formatter izlaz; }

izlaz.close();

public void otvoriFajl() {

try { izlaz = new Formatter("Radnici.txt", "UTF-8"); }

catch (FileNotFoundException e) { System.err.println("Greska pri otvaranju."); System.exit(1);

catch (UnsupportedEncodingException e) { System.err.println("Kodiranje nije podrzano.");
System.exit(1); }

public void upisiRadnikeUFajl() {

Radnik r = new Radnik();
Scanner unos = new Scanner(System.in);

System.out.print("Koliko radnika zelite da unesete? ");

int brojRadnika = unos.nextInt();

System.out.println("Unesite radnike u formatu: <ime> <prezime> <datum> <sprema>");
System.out.println("(<datum> unesite u formatu yyyy-mm-dd)");

for(int i = ©; i < brojRadnika; i++) {

r.setIme(unos.next());

r.setPrezime(unos.next());

r.setPocetak(LocalDate.parse(unos.next()));

r.setSprema(unos.nextInt());

izlaz.format("%s %s %s %d\n", r.getIme(), r.getPrezime(), r.getPocetak(), r.getSprema());
}

unos.close();




2 OBJEKTNO-ORIJENTISANI DIZAJN SOFTVERA

Kreiranje txt fajla 1 upis u fajl

public class TestiranjeUpisaUFajl {

public static void main(String[] args) {
UpisRadnikaUFajl fajlOper = new UpisRadnikaUFajl();
fajloper.otvoriFajl();
fajlOper.upisiRadnikeUFajl();
fajlOper.zatvoriFajl();

}
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Citanje podataka iz txt fajla

import java.io.File;

import java.io.FileNotFoundException; public void zatvoriFajl() {
import java.time.lLocalDate; if(ulaz != null)
import java.util.Scanner; ulaz.close();
}
public class CitanjeRadnikaIzFajla { }

private static Scanner ulaz;

public static void main(String[] args) {
otvoriFajl();
citajRadnikeIzFajla();
zatvoriFajl();

}

public static void otvoriFajl() {
try { ulaz = new Scanner(new File("Radnici.txt")); }
catch(FileNotFoundException e) { System.err.println("Greska pri otvaranju."); System.exit(1);

}

public static void citajRadnikeIzFajla() {
Radnik r = new Radnik();

while(ulaz.hasNext()) {
r.setIme(ulaz.next());
r.setPrezime(ulaz.next());
r.setPocetak(LocalDate.parse(ulaz.next()));
r.setSprema(ulaz.nextInt());

System.out.println(r);
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